Passthrough Authentication Setup Issues
Question asked by Kurt Nicklow - 9/29/2020 at 1:18 PM
Greetings! I'm new to File Vista and am having issues getting the Windows Authentication to work. This is to say that, when I check under "settings" and look at what credentials are being used to map a UNC path I'm seeing "Authenticated User: Windows" and under it, "Current User: (not found)".

I've made the following changes...

1. Changed the application pool to run under a domain service account that has local administrator access to the application server running GleamTech File Vista.

2. Updated the Web.Config file to include the following...
        <compilation targetFramework="4.0"/>
        <sessionState mode="InProc"/>
        <authentication mode="Windows" />

3. Updated the "providers" under Windows Authentication to reflect "Negotiate:Kerberos" (and disabled Kernal-mode authentication)...

I've tried to follow other posts on this issue but I can't figure out what the issue is, any thoughts?

1 Reply

Reply to Thread
Cem Alacayir Replied
Employee Post Marked As Answer
Please also disable "Anonymous Authentication" in IIS. Then "Current User" would show the authenticated user that IIS passes.

Reply to Thread