FileUltimate loading problem
Problem reported by Julio Loizaga - April 6, 2017 at 4:09 AM
Resolved
We are suffering an intermitent problem with FileUltimate. It work's fine, but sometimes, when you set the root folder, the animated progress circle appears, but folder content appears blank. No matters what you do, FileUltimate always appears blank. If you close your session or the web browser, and access again, it works perfect most of the times. We have captured the errors in Firefox, and always have the same three errors:
 
  • .../fu/library/all.js
  • .../fu/js/fileultimate.js
  • .../resoudelocalization.js
It seems that FileUltimate can't access to this files, but we don't know why.
 
Any clue about what's happening?
 
B.R.
 

4 Replies

Reply to Thread
0
Julio Loizaga Replied
Hello. We've more clues that could help to solve this problem. It looks like that in some circumstances FileUltimate loses references to .Net Identity users. If you refresh user credentials prior to display FileUltimate, it works fine. It's very strange, but session user credentials work fine in ASP.Net MVC page, but FileUltimate lose them. Is there some kind of caducity over the temporary files FileUltimate is using?.
0
Cem Alacayir Replied
Employee Post
If you are using ASP.NET impersonation (in web.config) you need to make sure ASP.NET temporary folder is writable by the user. Even if you do not use impersonation, it's possible ASP.NET is confused with permissions which it automatically sets when first installed but you can repair the permissions later:
 
  1. Open a Command window as an administrator (Start / Programs / Accessories, then right-click over Command Prompt, then choose "Run as administrator").
     
  2. Enter the following command:
    C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Aspnet_regiis.exe -ga domain\user
    Substitute your domain and user for domain\user in the example above. Also if your application pool is 32-bit replace Framework64 with Framework.
    You can understand if you app pool is 32 bit by going to IIS and checking if "Enable 32-bit applications" option is set in the Advanced Settings of the app pool.
     
 
 
0
jason dev Replied
I have a problem like that, is what someone could help me, please, 
0
Cem Alacayir Replied
Employee Post
This happens when you render DocumentViewer (DocumentUltimate) incorrectly in ASP.NET MVC, please check this:

Make sure you are not incorrectly calling RenderHead method (it can slow down the browser or cause rendering problems like the screenshot).

- It should be only inside <head> tag and should not be added multiple times inside <body> tag. This is how browsers work.

- if you are calling RenderHead multiple times in the same page, the same JS includes will be put in the page and browser will misbehave (you could see errors in the console).

Reply to Thread