How to set documentviewer permission in FileManager
Question asked by azure - 10/29/2020 at 12:48 PM
Answered
Hi,
I am using filemanager and trying to disable download/save/print for documents. I am able to disable FileManagerPermissions.Download | FileManagerPermissions.Copy | FileManagerPermissions.Print on the filemanager, but when user preview the file, the side panel shows the images and user and right click and open the image in new windows or save it. How can I disable that? I can't find a way to access the document viewer from the filemanager to set it's permissions. Or is there a way to disable the side panel?

2 Replies

Reply to Thread
0
Cem Alacayir Replied
Employee Post Marked As Answer
> the side panel shows the images and user and right click and open the image in new windows or save it.  

Are you using an old version? It's not allowed to right click on thumbnails in the side panel of DocumentViewer since many versions.
Check here:

FileManagerPermissions.Print permission controls DocumentViewerPermissions.DownloadAsPdf, DocumentViewerPermissions.Print, DocumentViewerPermissions.SelectText.
However as of current version other DocumentViewer permissions are not controlled from FileManager.


0
azure Replied
Yes I was using an old version.
I tried the latest version and have another problem, After I set the permission as below, preview button is disabled. Any idea? My goal is to only allow preview and disabled download and print.
                acl.AllowedPermissions = FileManagerPermissions.Extract | FileManagerPermissions.ListFiles | FileManagerPermissions.ListSubfolders | FileManagerPermissions.Preview | FileManagerPermissions.ReadOnly;
                acl.DeniedPermissions = FileManagerPermissions.Download | FileManagerPermissions.Copy | FileManagerPermissions.Print;


Reply to Thread