Error after updating to new version v7.4.2.0 CssLenth and DisplayMode
Question asked by Rhett Cawood - 6/7/2020 at 8:48 AM
Answered
Error    CS0433    The type 'CssLength' exists in both 'GleamTech.Common, Version=4.1.5.0, Culture=neutral, PublicKeyToken=a05198837413a6d8' and 'GleamTech.Core, Version=4.0.0.0, Culture=neutral, PublicKeyToken=a05198837413a6d8'

Anyone have any ideas to fix - have tried removing GleamTech.Core from packages.config - restarted visual studio - clean - rebuilt - still getting errors all over project... Help appreciated.

2 Replies

Reply to Thread
0
Cem Alacayir Replied
Employee Post Marked As Answer
Ensure there is no old DLL file named GleamTech.Core.dll anywhere in your project, it was replaced with new DLL file named GleamTech.Common.dll since Version 7.3.0 - November 20, 2019 

In Visual Studio: Go to Tools -> NuGet Package Manager -> Package Manager Console and run these commands one by one in order: 

Uninstall-Package FileUltimate -RemoveDependencies

Uninstall-Package FileUltimate.NuGetOrg -RemoveDependencies

Install-Package GleamTech.FileUltimate

If you are using direct DLL references instead of NuGet reference, first clean your project, remove references to old assembly GleamTech.Core.dll, add references to new assembly and rebuild your project. Ensure there is no GleamTech.Core.dll left in your project bin folders.
0
Rhett Cawood Replied
Cem you are a Superstar - Thank you problem solved - tomorrow we buy GleamTech File Ultimate- Support is brilliant... Any way you can do pricing in South African Rands?

Reply to Thread