Only in iPhone - DocumentViewer version 2.7 and 4.2: Session has expired, the page will be automatically refreshed in 10 seconds.
Problem reported by Alberto Pereira - 9/24/2018 at 1:57 AM
Resolved
Hello, we have this error message only in iPhones with any installed browser:
 

3 Replies

Reply to Thread
0
Alberto Pereira Replied
Hello, may be the problem has been caused by an iframe and cross domains (I forgot mention that the "DocumentUltimate" was inside of an iframe in another domain). I changed it to link with target="_blank" to same url of the iframe, and now its working.
 
Regards.
0
Jayesh C Replied
I did not understand your solution. Can you elaborate please?

0
Cem Alacayir Replied
Employee Post Marked As Resolution
FYI,
With FileUltimate v7.8.1 and DocumentUltimate v5.8.1 (November 23, 2020 updates), this issue is fixed out of the box for both ASP.NET Core and ASP.NET Classic (no settings required):

  • Added: Cookieless session will be used when necessary to automatically fix session issues, i.e. when the browser
    does not allow cookies via browser settings or via iframe with a cross-domain URL.
    The cookieless session will be established via headers, form or querystring where possible.

    Added GleamTechWebConfiguration.AutoCookielessSessionEnabled property to control this feature (default value is true).
    You don't need to use GleamTechWebConfiguration.CookieSameSiteFixEnabled when this property is true.

  • Fixed: When <sessionState cookieless="true" /> was set in Web.config, the below error was being thrown:
    'Invalid method request: Method with name "" not found'

Reply to Thread