Errors when using DocumentUltimate viewer using Chrome ONLY
Problem reported by Jeff Eynon - April 17 at 12:07 PM
Submitted
Hi, 
 
I have an application using DocumentUltimate viewer.  When I download the PDF getting generated on the server, I get one of two errors:
 
1.  Bad password or file corrupt
2.  Invalid XPZ document
 
This application is developed for us by a vendor, so unfortunately I don't have the source code.  They have pushed the issue onto us as an environmental issue because they cannot reproduce it.  I have noticed the following:
 
1.  It happens only in Chrome.  IE is fine.  
2.  Our application is public, so if I access the application from my personal computer at home (again using chrome), I don't get the error.
3.  The vendor has our application running on their servers, and if I access their version of our app using Chrome, it works fine.  
 
So the error happens only in Chrome, and only when accessing our application on our servers in our environment.  Our servers are load balanced and I did see some things about errors being caused by load balancing, but if that was the cause I would happen in all cases when access our application.  
 
Is there anything I can look at to help figure this out?

2 Replies

Reply to Thread
0
Cem Alacayir Replied
Employee Post
Your problem seems to be related to that specific Chrome instance.
 
"Invalid XPZ file" error usually happens when browser cache and file on the server cache does not match. For example if conversion failed unexpectedly on first view.
Probably you are getting that error on files that you tried earlier when you had a problem (on old version?).
The browser cached the resulting file (failed/currupted one) so force your browser with CTRL + F5. 
Also with Chrome you can hit F12 then while that below window is open, you can click and hold the refresh button near the address bar and you will see refresh options like “Empty Cache and Hard Load”
 
However "Bad password or file corrupt" error is unusual. Do you have any add-ons on your Chrome? Maybe something is interfering with the download requests. You should also try updating your Chrome version.
 
0
Hi, 
 
I tried the suggestions and I am still having the issue.  Is there anything else I can try?  Is it possible to get phone support or more interactive debugging/support?

Reply to Thread