ExcludedExtensionsForPreview does not exclude file extensions from preview
Problem reported by Lara Newsom - January 26 at 9:34 AM
Not A Problem
Any idea why ExcludedExtensionsForPreview is not working? I've also tried it with "*" and ".*" which also does not work. We want to disable all previewing since we are not able to pre-cache the files and some of our documents are taking over a minute to load in preview.
 
We are currently using FileUltimate version 5.16.0 and GleamTech.Core version 2.0.1 
 
            FileManager fileManager = new FileManager()
            {
                Width = Unit.Percentage(80),
                Height = 500,
                Resizable = true,
                DownloadOnDoubleClick = false,
                ViewLayout = ViewLayout.MediumIcons,
                ExcludedExtensionsForPreview = ".pdf, .xls, .doc, .docx"
            };
 

1 Reply

Reply to Thread
0
Cem Alacayir Replied
Employee Post
Hi,
Firstly you should not include dots before extensions in the property:
 
ExcludedExtensionsForPreview = "pdf, xls, doc, docx"
This way the property would work as expected but you would still need to list all extensions (no match-all setting here).
 
For disabling all previewing, instead you should deny Preview permission for your root folder:
 
var rootFolder = new FileManagerRootFolder
{
    Name = "My root folder",
    Location = "c:\root\folder"
};

rootFolder.AccessControls.Add(new FileManagerAccessControl
{
    Path = @"\",
    AllowedPermissions = FileManagerPermissions.Full,
    DeniedPermissions = FileManagerPermissions.Preview
});      

fileManager.RootFolders.Add(rootFolder);

Reply to Thread