UNC mapping / Folder name issues
Question asked by William Simpson - 7/13/2017 at 7:13 AM
I am trying to map a Folder on our network (AD) using the Connect As: Authenticated user: Windows
Type: Physical
Path: \\cscc.local\employee\home\{user}$ 
Name: home (is there a specific requirement for the Name here or can it be whatever I want it to be called?) I am using the last part of the mapping for it.
When I log in I get the following Action Error: (5) Access is denied: [[Employee]:\]
Rights are assigned via a Group and the Group has full access/rights to the Root Folder. Am I missing something?
My goal is each user when logged in sees only their home directory and the same for students.

3 Replies

Reply to Thread
Cem Alacayir Replied
Employee Post Marked As Answer
When you import users from Active Directory (or Local Machine), you should leave Connect as setting at Application User. They will be able to login on login.aspx page and they will be impersonated automatically when required (i.e. when accessing file system).
Authenticated user: Windows should be only selected when using Windows Authentication in IIS (when set in Web.config or in IIS Manager). So when you are using IIS Windows Authentication mode, you don't see FileVista login page and logged in automatically according to the current logged on Windows user (or see browser's own login dialog for Basic Authentication). In this mode, you don't import users. You just need to create a FileVista user with the same fully qualified name.

More info on importing users:

There is “Import Users” feature to import users from AD. By importing I mean, FileVista needs to create the same users in its database so that they can login. This is usually done once when you setup FileVista and maybe when you have new users in AD. So in short, as of current version this needs to be done manually (in administration page on “Import Users” dialog) there is no auto synchronization. However, when you change a password in AD, it will still work in FileVista. Only user name and some other properties for display purposes are saved in FileVista database. So you would need to reimport a user if the user name is changed. As of current version AD groups are not imported but you can create groups in FileVista and add imported AD users to them.
William Simpson Replied
So based on your instructions I went back and did an Import Users leaving the "Connect As:" field blank. I can import users, create groups and Root Folders except, still, when I try to pick the home directory I get you do not have permissions/rights.
I am mapping like this:  \\col.local\employee\home\{user}$
Root Folder name is "test".
I assume the Root Folder name can be random and not related to the specific mapped path, that accurate?
I am choosing Connect as: Application user per your instructions but to no avail. I know the user has rights because if I specifically state 'Specific User' then I can see the folders/files.
My goal is a Group for Employees to access their home directories and login using their AD accounts. I am sure there is something simple I am missing but nothing I try works.
Any further suggestions?
I have a problem with the user settings in the folders. I have an application that uses the active directory, and in the folders I use the user IIS_IUSRS (DOMAIN \ IIS_IUSRS) but the File Ultimate does not use this IIS user. in fact the File Ultimate uses is the user (DOMAIN \ Users) and not the one of IIS. is there any way for the Ultimate file to use the IIS? user, because by protocol I can not use (DOMAIN \ Users)
Victor Duarte

Reply to Thread