1
Could not load file or assembly
Problem reported by AHMED A - December 29, 2016 at 9:53 PM
Resolved
hello
after upgrade to documentultimate 2.1.5 and when browse page in vs.net 2015 IDE always return
 
Could not load file or assembly '...' or one of its dependencies. The system cannot find the file specified
 
after 4 or 5 time of refresh page the page run.

6 Replies

Reply to Thread
0
Cem Alacayir Replied
December 30, 2016 at 4:26 AM
Employee Post
Are you sure you upgraded to DocumentUltimate 2.1.5? Because this error was fixed in that version. Make sure you are not still using the 2.1.4 or older DLL.
0
Cem Alacayir Replied
January 2 at 6:05 PM
Employee Post
Please download v2.1.6 from this link:
link is removed as this version is live now
Reference both GleamTech.Core.dll and GleamTech.DocumentUltimate.dll files from this zip in your project (remove older versions and nuget packages) and let me know if the problem is completely fixed or not.
 
After you confirm it's working, v2.1.6 will be also available on Nuget shortly.
0
AHMED A Replied
January 2 at 8:05 PM
Thank you for all your assistance,now it's work (-:
0
Cem Alacayir Replied
January 11 at 4:36 PM
Employee Post
For future reference:
This problem was definitely fixed back in v2.1.6. However if anyone continues to get the same error message, this would be the reason:
 
There is a “Temporary ASP.NET files” folder where ASP.NET shadow copies your DLLs from bin folder. So, if this temp folder still has the old DLLs, the error would persist.
Normally when bin folder is updated, ASP.NET should automatically shadow-copy and overwrite old files. However, in some cases ASP.NET may fail to update (e.g. due to some native DLLs being locked on disk) so when you restart the application pool (or restart IIS) ASP.NET would shadow-copy successfully again.
 
If restarting the application pool or IIS does not solve the problem, please follow these steps to completely solve the issue:
 
  1. Stop IIS
     
  2. Delete the corresponding folder for your site in “Temporary ASP.NET Files”:
     
    C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\yoursite\XXXXX\
    Or for 32-bit process (if "Enable 32-bit apps" is enabled in app pool setting 32-bit version of w3wp.exe will be running and that would be using this folder):
     
    C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\yoursite\XXXXX\
    If you are running on Visual Studio so IIS Express then the folder would be:
     
    %UserProfile%\AppData\Local\Temp\Temporary ASP.NET Files\vs\XXXXX\
    If you can’t figure out which XXXXX subfolder to delete (there could be many), just delete the whole yoursite folder or if you don’t want to delete whole folders then just search for GleamTech in Windows Explorer when you are inside “Temporary ASP.NET Files” and delete all DLLs found in the search result. This will ensure you get rid of the old version of DLLs and let ASP.NET shadow-copy the new DLLs.
     
  3. Now when you start IIS and hit your site again then ASP.NET should cleanly shadow-copy all new DLLs and you should never see same error again.
0
John Replied
January 12 at 12:12 PM
I'm getting the Could not load file or assembly 'AlphaFS' error as well and I just installed it using NuGet.  I never ran any old versions.
0
Cem Alacayir Replied
January 26 at 5:16 AM
Employee Post
FYI, I think we completely fixed it now in v2.2.3. 
v2.2.3 is now live on the web site and nuget.
 
It turned out the error was due to a stupid bug: 
The log file AssemblyResolver.log was locked when you first started your web app as expected but even if you restarted the web app it could stay locked.
Then during the next web app initialization, AssemblyResolver would fail initialization because it could not overwrite the log file AssemblyResolver.log.
It was hard to replicate because the file did not stay locked after every restart/recycle.

Reply to Thread