1
Document Viewer blank pages
Problem reported by Jason Vetter - May 11, 2016 at 8:58 AM
Resolved
I recently upgraded to 5.1 and now to 5.3 and in both cases, the document viewer is not working.  It opens up fine, displays a message that the viewer is preparing the document for 1st time use, and then when it finishes, it displays the various pages in the left pane but the middle pane where the content should be is just a series of white/blank pages with no content.
 
 

2 Replies

Reply to Thread
0
Cem Alacayir Replied
May 11, 2016 at 9:26 AM
Employee Post
Document Viewer shows blank pages on some machines due to not being able to access system fonts.
In IIS, setting "Load User Profile" to true for the Application Pool will fix the problem. The problem is that it can not populate fonts from Registry if this setting is set to false. Note that by default IIS Application Pool's have this setting enabled.
 
After you do the change, make sure you clear the document cache (App_Data\DocumentCache) so that you force the Document Viewer to prepare the documents again, this time with access to fonts.
 
Let me know.
 
0
Cem Alacayir Replied
May 16, 2016 at 5:53 PM
Employee Post
Sorry, I need to clarify the document cache location for FileUltimate.
If you do not set TemporaryPath configuration property, then by default this path will be used:
 
C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\YOURSITE\XXXXXXXX\FileUltimate\DocumentCache
or for 32-bit process (ie. if “Enable 32-bit apps“ is enabled in IIS app pool settings):
 
C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files\YOURSITE\XXXXXXXX\FileUltimate\DocumentCache
So you should clear one of the above folders to clear document cache after you change "Load User Profile" setting in IIS.
 
For locating the cache folder easily in future, you may want to change the location to somewhere you know.
For example, you can change it by putting the below line into the Application_Start method of your Global.asax.cs:
 
FileUltimateConfiguration.Current.TemporaryPath = "~/App_Data/Temporary";
Alternatively you can specify the same setting in <appSettings> tag of your Web.config:
 
<appSettings>
  <add key="FileUltimate:TemporaryPath" value="~/App_Data/Temporary" />
</appSettings>
 

Reply to Thread